NX250 CDI issues

Open for English requests from all countries!
Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

NX250 CDI issues

Beitrag von scrambler » Di Dez 02, 2014 6:43 am

If the NX won’t start you can check two things. If the battery is weak, the starter will turn slowly or you will get only a “clack” sound from the starter relay (right side above the muffler) – check this with connecting with a car battery. If it’s still clacking, the starter relay is faulty.
If the starter engine is turning, but you won’t get a spark at the plug – the CDI is defective. Those defects often occur with a mean on/off modus – for instance, after some trying, the engine is suddenly running. The next couple of days it`ll start as usual, just until it fails again when you needed it least ;) . In some cases it helps (temporarily) wiggling at the CDI wiring, or boiling the CDI in hot water (no kidding).

But if you want your Nixie as reliable as before, you gotta change the CDI. And the biggest asset of the NX is its 100% reliability - I wouldn`t ruin it by saving a few bucks on a CDI :roll:

- China cdis are crap –the first one (from this seller http://www.ebay.co.uk/itm/Derestrict-Ig ... 1573708752) I tried, the tach didn’t work at all. I got a second one from China, but the tach did still not work. After 200km the CDI failed, and for the first time ever in 15 years I had to push my NX back home :evil:

- my first original CDI lasted 80.000km and there are no reports at all that new OEM CDIs failed – we’ll see after I finish 160.000km (still 50000km to go with the new OEM CDI)

- I tried a XL600V CDI once – this one got considerably more advanced ignition and my NX ran really strong with it – but not for long. First, the timing chain (which was new) skipped two teeth because the Transalp CDI lacks a special feature preventing the engine kicking back at very low revs during starting. Luckily it didn`t hurt the engine – but the power was gone
Bild
Shortly afterwards the lower connecting rod bearing gave up. Most likely the advanced ignition of the digital CDI was simply too much for the already worn out bearing.

- don’t try cdis from other bikes – most likely they also lack the kickback feature and from what I read they usually got much less advanced ignition and the NX will probably run like crap

- there are Japanese shindengen aftermarket (update dec 2015: out of stock!) CDIs from the same factory where the OEM ones come from. They are as good as stock and also labeled with KW3 CL548 or KW3H CL548A http://www.ebay.de/itm/NX-250-ZUNDBOX-C ... 230edb5e05
Bild
Any CDI without these markings are cheap China duplicates that are sold for big bucks
Bild
I especially like this fake one – some smart ass bought a couple of Chinese CDIS for a few bucks, put labels with “NX250 CDI” on it and sells it for 110$ :evil: These CDIs are even known causing charging problems (see below).

Bild

- OEM CDIs are very cheap in the US –if I would live there, I wouldn’t have to think much about what CDI to buy … http://www.partzilla.com/parts/detail/h ... 3-008.html

Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

Re: NX250 CDI issues

Beitrag von scrambler » Fr Nov 13, 2015 6:19 am

The charging system of the NX250 is usually very dependable. In more than 20 years I never experienced any battery problems, even with extensive use of heat grips during the winter. And I never heard of anybody else having battery problems – except for some US guys. They reported dead batteries shortly after changing the CDI.
Usually the CDI does not not have anything to do with the charging system, but there is one specialty of the NX250 CDI: it is connected to the alternator (yellow cable), something which no other CDI (to my knowledge) got.

Bild

So apparently some aftermarket CDIs on Ebay US (see pic below) have a ground fault, causing charging issues.

Bild

Now the best would be to get a new OEM CDI, for the time beeing you could try the following: disconnect the yellow cable that connects the CDI with the alternator. The connection is under the seat in that little box. I haven’t tried this myself so I don’t know if that will work and if you will get a spark at the plug (with the origional CDI you won`t but some aftermarket CDI will work without the yellow connection).

Bild

estebangc
Beiträge: 73
Registriert: Di Nov 25, 2014 4:29 pm
Wohnort: Sevilla (E) / Schweiz

Re: NX250 CDI issues

Beitrag von estebangc » Sa Nov 14, 2015 8:41 pm

Srambler, thanks so much for all the info that you share with us.

Now one question regarding a possible CDI failure (or another electrical issue). Fist off, the bike has been stopped for a long time, and I had to get it ready for the TüV, which has taken me long for several reasons (baby).

Since I bought the NX, it happens that sometimes I press the start button and the starter doesn't turn at all. It just happens absolutely nothing. It is not a battery issue (fully charged). It happened specially when I had touched the button to cut the ignition, so I just stopped touching it. It just needed some time to be ready again to start, maybe 30 minutes or a day (depending on my patience or willingness to stay there, but I could not ride due to the TüV so I did not worry).

So, I passed the TüV and have been going around a few days with it. Last week, I just stopped in a gas station and when I tried to start it, NOTHING. Well, I just parked it there and came two day later. NOTHING, the starter did not turn at all. One week later, NOTHING.

The question: how to find if it is a CDI issue or just an electrical issue?

I understand that if it is a bad electrical contact, particularly in the handle lever switch "thing" (in Spanish "piña", where all the buttons are), I would be able to push the bike and start it in 2nd gear. By contrast, if it is a CDI issue, I won't be able to start it pushing it. Am I right?

Thanks in advance, any comments are very welcome.

Esteban

Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

Re: NX250 CDI issues

Beitrag von scrambler » So Nov 15, 2015 8:00 am

estebangc hat geschrieben: Since I bought the NX, it happens that sometimes I press the start button and the starter doesn't turn at all.
Hi,
this sounds very much like a bad contact in the right handle lever switch. But before repairing/replacing it make sure that the battery is really ok. So the next time the NX won’t start attach a car battery – if the problem continues you can exclude the battery. Now while you are at it – when you push the starter button listen closely to the right side cover – do you hear a “clack”? If so, it’s a bad starter relay (happens sometimes). If you don’t hear a clack you can exclude the starter relay, too. The CDI as well – a bad CDI would not influence the starter itself, meaning the starter would turn but you would not get a spark at the plug.
If you look at the wiring of the right handle switch you will notice that they the “stop” and the “starter” buttons are connected with a switch – so apparently that’s the source of the problem.
I had this problem myself, but since I’m an electrical dummy, I did not try to repair and changed the switch – so, sorry, no instruction from me on this topic :) .

Cheers, Michael
Motoraus_schalter_vgl.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

estebangc
Beiträge: 73
Registriert: Di Nov 25, 2014 4:29 pm
Wohnort: Sevilla (E) / Schweiz

Re: NX250 CDI issues

Beitrag von estebangc » So Nov 15, 2015 11:44 pm

Hi Scrambler,

Thanks so much for the answer. I will follow all the procedure, but the battery is new, it was fully charged at home and it ran great until I stopped, but I will check it.

I am absolutely an electrical dummy, and I am pretty sure that pressing the start button does not produce any noise, although I will soon check it out as well. In that case, if you still remember it, where did you buy the new switch?

So, to my best understanding, it should definitely start pushing the bike.

mfG,

Esteban

Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

Re: NX250 CDI issues

Beitrag von scrambler » Mo Nov 16, 2015 8:30 am

estebangc hat geschrieben: I am absolutely an electrical dummy, and I am pretty sure that pressing the start button does not produce any noise, although I will soon check it out as well. In that case, if you still remember it, where did you buy the new switch?

You could first try “contact spray” (I don’t know if this is actually the right term - I mean something like that http://www.ebay.de/itm/16-80-1l-Caramba ... Sw~uhUnpo9) spraying into the switch.
If it’s only rust or dirt and old grease that may help. If the contacts are worn out probably not – I had this at ca 80.000km when the contact spray did not work anymore.
I got a used switch then – but they are hard to get and expensive. That’s the only one I can find right now http://www.bike-teile.de/index.php?seit ... id=1495228#
New ones are still available, not that cheap, too http://www.cmsnl.com/products/sw-assy-l ... 150kw3000/ but they will last a long time
lenkerschalter rechts.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

marcus
Beiträge: 26
Registriert: Di Dez 15, 2015 7:23 pm
Wohnort: FRANCE - near Paris

Re: NX250 CDI issues

Beitrag von marcus » Di Dez 29, 2015 4:59 pm

Hi,
In this post it is written:
<< In some cases it helps (temporarily) wiggling at the CDI wiring, or boiling the CDI in hot water (no kidding). >>

Today I have no spark at the plug, i think my CDI has a problem.
My NX250 is from 1990.

I would liked to put my CDI in boiling water, as it is said before. Do you know, how long time I have to keep my CDI in boiling water ?

Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

Re: NX250 CDI issues

Beitrag von scrambler » Mi Dez 30, 2015 9:08 am

marcus hat geschrieben:Hi,
In this post it is written:
<< In some cases it helps (temporarily) wiggling at the CDI wiring, or boiling the CDI in hot water (no kidding). >>

Today I have no spark at the plug, i think my CDI has a problem.
My NX250 is from 1990.

I would liked to put my CDI in boiling water, as it is said before. Do you know, how long time I have to keep my CDI in boiling water ?
I haven’t tried this, but 40-60 seconds should be enough. But in any case it’s only a temporary fix, for instance while traveling.
Unfortunately, the Japanese shindengen aftermarket CDIs are out of stock. I still got a few left for cases of emergencies in the forum ;-).
It looks like that CMS still got some OEM CDIs left (http://www.cmsnl.com/honda-nx2502-domin ... ml#results), but they are pretty expensive (almost 300€ plus shipping :shock: ).

marcus
Beiträge: 26
Registriert: Di Dez 15, 2015 7:23 pm
Wohnort: FRANCE - near Paris

Re: NX250 CDI issues

Beitrag von marcus » Mi Dez 30, 2015 3:36 pm

Thank you Scrambler,
Today on ebay I have seen that, CDI at 132.50 €
Do you think this CDI is a good one ?

http://www.ebay.fr/itm/CDI-Steuergerat- ... SwWnFWAdwh

Seller:
tommotec Inh.
Spinnerweg 51-54
53783 Eitorf
Deutschland
http://www.tommotec.de

Benutzeravatar
scrambler
Site Admin
Beiträge: 2161
Registriert: Fr Sep 14, 2012 8:50 am

Re: NX250 CDI issues

Beitrag von scrambler » Do Dez 31, 2015 8:31 am

marcus hat geschrieben:Thank you Scrambler,
Today on ebay I have seen that, CDI at 132.50 €
Do you think this CDI is a good one ?
Frankly, I don't know. It looks like (because it seem to be longer than stock) that it's a CDI from another bike.

The same applies to this one, but its at least much cheaper. http://www.ebay.fr/itm/371427105946?ru= ... 1#shpCntId

But the seller offers a one-year guarantee, so if anything is the matter (but be sure to keep the recipt) you can send the CDI back.

Cheers, Michael

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast